22
2021
02

FPGA ALARM FPGA多功能闹钟 上位机源码

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _关于_被选择

信息框 (“软件用途:基于小脚丫FPGA开发板设计的智能闹钟上位机” + #换行符 + “版权所有:MyFPGA.cn ChanRa1n 保留所有权利” + #换行符 + “项目网址:https://www.myfpga.cn”, 0, “关于”, )

.子程序 _按钮1_被单击

端口1.端口号 = 到整数 (编辑框_端口号.内容)
端口1.波特率 = 到整数 (编辑框_波特率.内容)
端口1.奇偶校验 = 假
端口1.停止位数 = 1
端口1.启动 ()

.子程序 _端口1_数据到达
.参数 数据字节值, 整数型
.局部变量 mode, 整数型
.局部变量 data, 整数型

' 00 05 73 40 50 24 37
mode = 数据字节值 ÷ 16

data = 数据字节值 % 16
' 调试输出 (到文本 (数据字节值))

.如果真 (mode = 0)
    data_temp_a = data
.如果真结束

.如果真 (mode = 1)
    data_temp_b = data
.如果真结束

.如果真 (mode = 2)
    data_temp_c = data
.如果真结束


.如果真 (mode = 3)
    data_time_a = data
.如果真结束


.如果真 (mode = 4)
    data_time_b = data
.如果真结束


.如果真 (mode = 5)
    data_time_c = data
.如果真结束


.如果真 (mode = 6)
    data_time_d = data
.如果真结束

标签4.标题 = 到文本 (data_time_a) + 到文本 (data_time_b) + “:” + 到文本 (data_time_c) + 到文本 (data_time_d)
标签5.标题 = 到文本 (data_temp_a) + 到文本 (data_temp_b) + “.” + 到文本 (data_temp_c) + “℃”



.子程序 音乐转换, 整数型
.参数 简谱值, 文本型

.如果真 (取文本左边 (简谱值, 1) = “H”)
    返回 (到整数 (取文本右边 (简谱值, 1)) + 14)
.如果真结束

.如果真 (取文本左边 (简谱值, 1) = “M”)
    返回 (到整数 (取文本右边 (简谱值, 1)) + 7)
.如果真结束

.如果真 (取文本左边 (简谱值, 1) = “L”)
    返回 (到整数 (取文本右边 (简谱值, 1)))
.如果真结束

返回 (1)  ' 防错误

.子程序 _时钟1_周期事件

.如果真 (data_time_c = 0)
    .如果真 (data_time_d = 0)
        .如果真 (data_time_a × 10 + data_time_b ≤ 20)
            .如果真 (data_time_a × 10 + data_time_b ≥ 6)
                ' 只有当早上6点至晚上20点才触发警报
                .如果真 (上一警报 ≠ data_time_a × 10 + data_time_b)
                    ' 避免一个小时触发多次
                    上一警报 = data_time_a × 10 + data_time_b
                    发送音乐 ()
                .如果真结束

            .如果真结束

        .如果真结束

    .如果真结束

.如果真结束


.子程序 发送音乐
.局部变量 待播放队列, 文本型

待播放队列 = 编辑框1.内容

.判断循环首 (待播放队列 ≠ “”)
    调试输出 (到文本 (音乐转换 (取文本左边 (待播放队列, 2))))
    端口1.发送数据 (音乐转换 (取文本左边 (待播放队列, 2)))
    待播放队列 = 取文本右边 (待播放队列, 取文本长度 (待播放队列) - 3)
    延时 (500)
.判断循环尾 ()

端口1.发送数据 (0)

.子程序 __启动窗口_创建完毕



.子程序 _帮助_被选择

网页_打开指定网址 (“https://www.myfpga.cn/?id=183”)


全局变量

.版本 2

.全局变量 data_temp_a, 整数型
.全局变量 data_temp_b, 整数型
.全局变量 data_temp_c, 整数型
.全局变量 data_time_a, 整数型
.全局变量 data_time_b, 整数型
.全局变量 data_time_c, 整数型
.全局变量 data_time_d, 整数型
.全局变量 上一警报, 整数型


启动窗口

image.png


完整的易语言源码和模块

上位机.zip


« 上一篇 下一篇 »

返回顶部
请先 登录 再评论,若不是会员请先 注册